Install the lastest gedit (version 3.20.2) on Ubuntu 16.04

Lets go!

wget http://ftp.gnome.org/pub/GNOME/sources/gedit/3.20/gedit-3.20.2.tar.xz 
tar xvf gedit-3.20.2.tar.xz
cd gedit-3.20.2
./configure

configure: WARNING:
  You will not be able to create source packages with 'make dist'
  because gtk-doc >= 1.0 is not found.

./configure: line 13872: intltool-update: command not found
checking for intltool >= 0.50.1...  found
configure: error: Your intltool is too old.  You need intltool 0.50.1 or later.

checking for GSPELL... no
configure: error: gspell library not found or too old. Use --disable-spell to build without spell plugin.

To fix the first tow errors you need to install the following files:
sudo apt-get install gtk-doc-tools intltool

Now, we download gspell:

sudo apt install git
git clone https://github.com/GNOME/gspell.git
cd gspell/
./autogen.sh

configure.ac:142: error: macro GOBJECT_INTROSPECTION_CHECK is not defined; is a m4 file missing?
/usr/share/aclocal/ax_require_defined.m4:35: AX_REQUIRE_DEFINED is expanded from...
configure.ac:142: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: error: echo failed with exit status: 1

To solve it, we need the dependencies of gedit:
sudo apt-get build-dep gedit

Now, come back to autocofigure:
./autogen.sh
configure: error: Package requirements (glib-2.0 >= 2.44  gtk+-3.0 >= 3.19.11 enchant >= 1.6.0) were not met:

Requested 'gtk+-3.0 >= 3.19.11' but version of GTK+ is 3.18.9

We require the last version of gtk:

wget http://ftp.gnome.org/pub/gnome/sources/gtk+/3.21/gtk+-3.21.4.tar.xz
tar xvf gtk+-3.21.4.tar.xz
 cd gtk+-3.21.4/
./autogen.sh

Requested 'glib-2.0 >= 2.49.3' but version of GLib is 2.48.1

Now, we need the last version of glib:
wget http://ftp.gnome.org/pub/gnome/sources/glib/2.49/glib-2.49.4.tar.xz
tar xvf glib-2.49.4.tar.xz
cd glib-2.49.4
./autogen.sh
./configure
make && sudo make install

Come back to the other apps and compile them.
When you will return to gedit, this error will appear:

Requested 'gtksourceview-3.0 >= 3.19.4' but version of gtksourceview is 3.18.2

Download and compile it:
wget http://ftp.gnome.org/mirror/gnome.org/sources/gtksourceview/3.21/gtksourceview-3.21.3.tar.xz
tar xvf gtksourceview-3.21.3.tar.xz
cd gtksourceview-3.21.3/
./configure
make && sudo make install

Come back to gedit, configure and compile it.





















Enjoy it!

Comments

  1. sudo apt-get build-dep gedit

    doesn't work, assume i need ppa here

    ReplyDelete
    Replies
    1. Did you uncomment deb-src lines in /etc/apt/sources.list?

      Delete

Post a Comment

Popular posts from this blog

How to fix Android when developer options are not available for this user

from: can't read /var/mail/ in Python scripts

Fix "Set scan parameters failed: Input/output error" on Ubuntu 16.04